use strict;
my $str = 'x ^ 2 -> x²
x ^ (2 - 6)
x ^ (2 - [6 + {x + y }])
x ^ y
3x ^ 7y
z ^ y2
9 ^ √4
9 ^ 30
2^1000000
x ^ (2 - 1) + 3 - 5';
my $regex = qr/\s*\^\s*(\(.*.\)|\S+)/p;
my $subst = '<sup>$1</sup>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";