# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*\^\s*(\(.*.\)|\S+)"
test_str = ("x ^ 2 -> x²\n"
"x ^ (2 - 6)\n"
"x ^ (2 - [6 + {x + y }])\n"
"x ^ y\n"
"3x ^ 7y\n"
"z ^ y2\n"
"9 ^ √4\n"
"9 ^ 30\n"
"2^1000000\n"
"x ^ (2 - 1) + 3 - 5")
subst = "<sup>$1</sup>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.