using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\^\s*(\(.*.\)|\S+)";
string substitution = @"<sup>$1</sup>";
string input = @"x ^ 2 -> x²
x ^ (2 - 6)
x ^ (2 - [6 + {x + y }])
x ^ y
3x ^ 7y
z ^ y2
9 ^ √4
9 ^ 30
2^1000000
x ^ (2 - 1) + 3 - 5";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}