re = /\s*\^\s*(\(.*.\)|\S+)/
str = 'x ^ 2 -> x²
x ^ (2 - 6)
x ^ (2 - [6 + {x + y }])
x ^ y
3x ^ 7y
z ^ y2
9 ^ √4
9 ^ 30
2^1000000
x ^ (2 - 1) + 3 - 5'
subst = '<sup>$1</sup>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result