const regex = /\s*\^\s*(\(.*.\)|\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\^\\s*(\\(.*.\\)|\\S+)', 'g')
const str = `x ^ 2 -> x²
x ^ (2 - 6)
x ^ (2 - [6 + {x + y }])
x ^ y
3x ^ 7y
z ^ y2
9 ^ √4
9 ^ 30
2^1000000
x ^ (2 - 1) + 3 - 5`;
const subst = `<sup>$1</sup>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);