import Foundation
let pattern = #"\s*\^\s*(\(.*.\)|\S+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
x ^ 2 -> x²
x ^ (2 - 6)
x ^ (2 - [6 + {x + y }])
x ^ y
3x ^ 7y
z ^ y2
9 ^ √4
9 ^ 30
2^1000000
x ^ (2 - 1) + 3 - 5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<sup>$1</sup>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)