// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*\^\s*(\(.*.\)|\S+)").unwrap();
let string = "x ^ 2 -> x²
x ^ (2 - 6)
x ^ (2 - [6 + {x + y }])
x ^ y
3x ^ 7y
z ^ y2
9 ^ √4
9 ^ 30
2^1000000
x ^ (2 - 1) + 3 - 5";
let substitution = "<sup>$1</sup>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}