# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(((https?|ftp):\\/\\/[\w?!=&.\\/-;#@~%+*-]+(?![\w\s?!&.\\/;#~%"=-]>))|((magnet):[\w?=&.\\/-;#@~%+*-]+))/<a href="$1" rel="nofollow">$1<\/a>/igm;t' <<< "<?php
```
<?php
```
https://test.de
### headline
</code>"