#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(((https?|ftp):\/\/[\w?!=&.\/-;#@~%+*-]+(?![\w\s?!&.\/;#~%"=-]>))|((magnet):[\w?=&.\/-;#@~%+*-]+))"
Local $sString = "<?php" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"<?php" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"https://test.de" & @CRLF & _
"" & @CRLF & _
"### headline" & @CRLF & _
"" & @CRLF & _
"</code>"
Local $sSubst = "<a href="$1" rel="nofollow">$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)