import Foundation
let pattern = ##"(((https?|ftp):\/\/[\w?!=&.\/-;#@~%+*-]+(?![\w\s?!&.\/;#~%"=-]>))|((magnet):[\w?=&.\/-;#@~%+*-]+))"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ####"""
<?php
```
<?php
```
https://test.de
### headline
</code>
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="$1" rel="nofollow">$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)