re = /(((https?|ftp):\/\/[\w?!=&.\/-;#@~%+*-]+(?![\w\s?!&.\/;#~%"=-]>))|((magnet):[\w?=&.\/-;#@~%+*-]+))/im
str = '<?php
```
<?php
```
https://test.de
### headline
</code>'
subst = '<a href="$1" rel="nofollow">$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result