use strict;
my $str = '<?php
```
<?php
```
https://test.de
### headline
</code>';
my $regex = qr/(((https?|ftp):\/\/[\w?!=&.\/-;#@~%+*-]+(?![\w\s?!&.\/;#~%"=-]>))|((magnet):[\w?=&.\/-;#@~%+*-]+))/imp;
my $subst = '<a href="$1" rel="nofollow">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";