# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(((https?|ftp):\/\/[\w?!=&.\/-;#@~%+*-]+(?![\w\s?!&.\/;#~%\"=-]>))|((magnet):[\w?=&.\/-;#@~%+*-]+))"
test_str = ("<?php\n\n"
"```\n"
"<?php\n"
"```\n\n"
"https://test.de\n\n"
"### headline\n\n"
"</code>")
subst = "<a href=\"$1\" rel=\"nofollow\">$1</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.