const regex = /(((https?|ftp):\/\/[\w?!=&.\/-;#@~%+*-]+(?![\w\s?!&.\/;#~%"=-]>))|((magnet):[\w?=&.\/-;#@~%+*-]+))/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((https?|ftp):\\\/\\\/[\\w?!=&.\\\/-;#@~%+*-]+(?![\\w\\s?!&.\\\/;#~%"=-]>))|((magnet):[\\w?=&.\\\/-;#@~%+*-]+))', 'igm')
const str = `<?php
\`\`\`
<?php
\`\`\`
https://test.de
### headline
</code>`;
const subst = `<a href="$1" rel="nofollow">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);