$re = '/(((https?|ftp):\/\/[\w?!=&.\/-;#@~%+*-]+(?![\w\s?!&.\/;#~%"=-]>))|((magnet):[\w?=&.\/-;#@~%+*-]+))/im';
$str = '<?php
```
<?php
```
https://test.de
### headline
</code>';
$subst = "<a href=\"$1\" rel=\"nofollow\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;