# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(bmp|gif|png|jpg|jpeg)$/.\1.gz/gm;t' <<< "foo.bmp
bar.gif"