const regex = /\.(bmp|gif|png|jpg|jpeg)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(bmp|gif|png|jpg|jpeg)$', 'gm')
const str = `foo.bmp
bar.gif`;
const subst = `.\1.gz`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);