#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.(bmp|gif|png|jpg|jpeg)$"
Local $sString = "foo.bmp" & @CRLF & _
"bar.gif"
Local $sSubst = ".\1.gz"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)