// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.(bmp|gif|png|jpg|jpeg)$").unwrap();
let string = "foo.bmp
bar.gif";
let substitution = ".\\1.gz";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}