re = /\.(bmp|gif|png|jpg|jpeg)$/m
str = 'foo.bmp
bar.gif'
subst = '.\\1.gz'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result