use strict;
my $str = 'foo.bmp
bar.gif';
my $regex = qr/\.(bmp|gif|png|jpg|jpeg)$/mp;
my $subst = '.\\1.gz';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";