# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<number>)(?:\s*<number>)+/\1/gm;t' <<< "\"<number> <number>\" -> \"<number>\"
\"<number><number>\"-> \"<number>\"
but not
\"<number> test <number>\" -> \"<number> test <number>\""