package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<number>)(?:\s*<number>)+`)
var str = `"<number> <number>" -> "<number>"
"<number><number>"-> "<number>"
but not
"<number> test <number>" -> "<number> test <number>"`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}