#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<number>)(?:\s*<number>)+"
Local $sString = ""<number> <number>" -> "<number>"" & @CRLF & _
""<number><number>"-> "<number>"" & @CRLF & _
"but not" & @CRLF & _
"" & @CRLF & _
""<number> test <number>" -> "<number> test <number>""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)