import Foundation
let pattern = #"(<number>)(?:\s*<number>)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"<number> <number>" -> "<number>"
"<number><number>"-> "<number>"
but not
"<number> test <number>" -> "<number> test <number>"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)