import re
regex = re.compile(r"(<number>)(?:\s*<number>)+", flags=re.MULTILINE)
test_str = ("\"<number> <number>\" -> \"<number>\"\n"
"\"<number><number>\"-> \"<number>\"\n"
"but not\n\n"
"\"<number> test <number>\" -> \"<number> test <number>\"")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)