// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<number>)(?:\s*<number>)+").unwrap();
let string = "\"<number> <number>\" -> \"<number>\"
\"<number><number>\"-> \"<number>\"
but not
\"<number> test <number>\" -> \"<number> test <number>\"";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}