import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<number>)(?:\\s*<number>)+";
final String string = "\"<number> <number>\" -> \"<number>\"\n"
+ "\"<number><number>\"-> \"<number>\"\n"
+ "but not\n\n"
+ "\"<number> test <number>\" -> \"<number> test <number>\"";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}