# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a href="">(.*?)<\\/a>/<a href="$1">$1<\/a>/gm;t' <<< "<a href=\"\">xxx</a>
<a href=\"\">yyy</a>
<a href=\"\">zzz</a>"