const regex = /<a href="">(.*?)<\/a>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href="">(.*?)<\\\/a>', 'gm')
const str = `<a href="">xxx</a>
<a href="">yyy</a>
<a href="">zzz</a>`;
const subst = `<a href="$1">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);