re = /<a href="">(.*?)<\/a>/m
str = '<a href="">xxx</a>
<a href="">yyy</a>
<a href="">zzz</a>'
subst = '<a href="$1">$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result