#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<a href="">(.*?)<\/a>"
Local $sString = "<a href="">xxx</a>" & @CRLF & _
"<a href="">yyy</a>" & @CRLF & _
"<a href="">zzz</a>"
Local $sSubst = "<a href="$1">$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)