using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href="">(.*?)<\/a>";
string substitution = @"<a href=""$1"">$1</a>";
string input = @"<a href="">xxx</a>
<a href="">yyy</a>
<a href="">zzz</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}