$re = '/<a href="">(.*?)<\/a>/m';
$str = '<a href="">xxx</a>
<a href="">yyy</a>
<a href="">zzz</a>';
$subst = "<a href=\"$1\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;