use strict;
my $str = '<a href="">xxx</a>
<a href="">yyy</a>
<a href="">zzz</a>';
my $regex = qr/<a href="">(.*?)<\/a>/mp;
my $subst = '<a href="$1">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";