import re
regex = re.compile(r"<a href=\"\">(.*?)<\/a>", flags=re.MULTILINE)
test_str = ("<a href=\"\">xxx</a>\n"
"<a href=\"\">yyy</a>\n"
"<a href=\"\">zzz</a>")
subst = "<a href=\"$1\">$1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)