package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a href="">(.*?)<\/a>`)
var str = `<a href="">xxx</a>
<a href="">yyy</a>
<a href="">zzz</a>`
var substitution = "<a href="$1">$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}