# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(size)=[^:]:([^\]\[]*)\]([^\[\]]*)\[\\/\1:\2]/$3/gm;t' <<< "outer [size=5:24f81ld3]inner text[/size:24f81ld3] outer
outer [size=100:24f81ld3]inner text[/size:24f81ld3] outer"