#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[(size)=[^:]:([^\]\[]*)\]([^\[\]]*)\[\/\1:\2]"
Local $sString = "outer [size=5:24f81ld3]inner text[/size:24f81ld3] outer" & @CRLF & _
"outer [size=100:24f81ld3]inner text[/size:24f81ld3] outer"
Local $sSubst = "$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)