using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(size)=[^:]:([^\]\[]*)\]([^\[\]]*)\[\/\1:\2]";
string substitution = @"$3";
string input = @"outer [size=5:24f81ld3]inner text[/size:24f81ld3] outer
outer [size=100:24f81ld3]inner text[/size:24f81ld3] outer";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}