import Foundation
let pattern = #"\[(size)=[^:]:([^\]\[]*)\]([^\[\]]*)\[\/\1:\2]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
outer [size=5:24f81ld3]inner text[/size:24f81ld3] outer
outer [size=100:24f81ld3]inner text[/size:24f81ld3] outer
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)