$re = '/\[(size)=[^:]:([^\]\[]*)\]([^\[\]]*)\[\/\1:\2]/m';
$str = 'outer [size=5:24f81ld3]inner text[/size:24f81ld3] outer
outer [size=100:24f81ld3]inner text[/size:24f81ld3] outer';
$subst = "$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;