re = /\[(size)=[^:]:([^\]\[]*)\]([^\[\]]*)\[\/\1:\2]/m
str = 'outer [size=5:24f81ld3]inner text[/size:24f81ld3] outer
outer [size=100:24f81ld3]inner text[/size:24f81ld3] outer'
subst = '$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result