const regex = /\[(size)=[^:]:([^\]\[]*)\]([^\[\]]*)\[\/\1:\2]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(size)=[^:]:([^\\]\\[]*)\\]([^\\[\\]]*)\\[\\\/\\1:\\2]', 'gm')
const str = `outer [size=5:24f81ld3]inner text[/size:24f81ld3] outer
outer [size=100:24f81ld3]inner text[/size:24f81ld3] outer`;
const subst = `$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);