use strict;
my $str = 'outer [size=5:24f81ld3]inner text[/size:24f81ld3] outer
outer [size=100:24f81ld3]inner text[/size:24f81ld3] outer';
my $regex = qr/\[(size)=[^:]:([^\]\[]*)\]([^\[\]]*)\[\/\1:\2]/mp;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";