import re
regex = re.compile(r"\[(size)=[^:]:([^\]\[]*)\]([^\[\]]*)\[\/\1:\2]", flags=re.MULTILINE)
test_str = ("outer [size=5:24f81ld3]inner text[/size:24f81ld3] outer\n"
"outer [size=100:24f81ld3]inner text[/size:24f81ld3] outer")
subst = "$3"
result = regex.sub(subst, test_str)
if result:
print(result)