import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(size)=[^:]:([^\\]\\[]*)\\]([^\\[\\]]*)\\[\\/\\1:\\2]";
final String string = "outer [size=5:24f81ld3]inner text[/size:24f81ld3] outer\n"
+ "outer [size=100:24f81ld3]inner text[/size:24f81ld3] outer";
final String subst = "$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}