# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'([^@']*@\d[^@']*)'/$1/gm;t' <<< "'package@1.1.k' 'otherpackage@14' 'anotherpackage@7.8'
export MYVAR=\"/dir/'package@1.1.k':$MYVAR\""