import Foundation
let pattern = #"'([^@']*@\d[^@']*)'"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'package@1.1.k' 'otherpackage@14' 'anotherpackage@7.8'
export MYVAR="/dir/'package@1.1.k':$MYVAR"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)