use strict;
my $str = '\'package@1.1.k\' \'otherpackage@14\' \'anotherpackage@7.8\'
export MYVAR="/dir/\'package@1.1.k\':$MYVAR"';
my $regex = qr/'([^@']*@\d[^@']*)'/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";